Unknown Me

使用 Composer 安装 Laravel

最新版

目前是 v5.2,project_name 改为你要的目录名就好

composer create-project laravel/laravel project_name --prefer-dist -vvv

特定版本

v5.1

composer create-project laravel/laravel project_name "5.1.*" --prefer-dist -vvv

小技巧

  • 如果有权限问题,在前面加 sudo
  • 加上参数-vvv会有详细日志,再也不用以为卡死啦

常用扩展

  • 执行 composer require barryvdh/laravel-ide-helper
  • config/app.php 增加 Barryvdh\LaravelIdeHelper\IdeHelperServiceProvider::class,
  • 执行 php artisan ide-helper:generate
  • 执行 composer require barryvdh/laravel-debugbar
  • config/app.php 增加 Barryvdh\Debugbar\ServiceProvider::class,